SecurID app is temporarily unavailable on Google Play
Incident Report for RSA Community
Postmortem

Postmortem / Root Cause Analysis

Up to version 4.0, the SecurID App was classified as a 'standalone' app by the Google Play app store. With the addition of cloud-based MFA features in 4.0 (e.g., push to approve), on 15th April, Google reclassified retroactively the app as a 'connected mode' app. For connected mode apps, Google requires that app developers provide an account with which to test the app’s connected features.

With the separation of RSA from Dell, the Google team sent notification if this new requirement (including a deadline on 1st May) to an old email address, which is no longer monitored. SecurID has corrected the issue and provided the Google team with a test account. After successful testing, Google has approved and re-listed the SecurID 4.0 app."

Mitigations

SecurID is continuously taking steps to improve the SecurID services and processes to help ensure such incidents do not occur in the future. This includes, but is not limited to:

  • The app store email policy has been updated so future emails are sent to multiple contacts so future emails can’t be lost.
  • Going forward, future versions of the app will only be submitted as a connected app, with the required test credential, so there will be no reclassification risk in the future.
Posted May 03, 2022 - 12:11 EDT

Resolved
UPDATE as of May 2, 2022 16:00 GMT:
The SecurID App has been restored to Google Play. The SecurID App can be found be searching “SecurID” on Google Play or via this link: https://play.google.com/store/apps/details?id=com.rsa.securidapp

We apologize for any inconvenience this may have caused to users.
Posted May 02, 2022 - 12:01 EDT
Update
Update as of May 2, 2022, 13:14 GMT
SecurID is aware that the SecurID App is unavailable on Google Play. We are actively working to restore the SecurID App to Google Play.

We currently do not have an estimated time when the SecurID App will be restored. We will share an update as soon as we have it.

To get notifications on the issue progress, please subscribe to our status page: https://securidcommunity.statuspage.io/

We apologize for the inconvenience and appreciate your patience during this time.
Posted May 02, 2022 - 09:53 EDT
Identified
SecurID is aware that the SecurID App is currently unavailable on Google Play at this time.

We are working to resolve this in order to restore the SecurID app on Google Play as soon as possible.

We apologize for the inconvenience and appreciate your patience during this time.
Posted May 01, 2022 - 19:30 EDT
This incident affected: RSA Community (Downloads).